Mapguide 6.5 Server Not Found on Hardened Windows 2008 Server

It seems I’ve become the “go to guy” when it comes to Mapguide 6.5 on modern platforms!   This post builds on my previous post that documents how to install Mapguide 6.5 on Windows 2008.  In this edition we look at the situation faced on a clients server.   Basically the installation went off without a hitch with one exception.  When attempting to test the Mapguide 6.5 ISAPI the following error occurred:

HTTP Error 500.19 – Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid

Odd – but I realized immediately this server felt different.  I added the Local Computer \ Users group to the folder permissions for the MapAgents folder and gave that group Read and Execute.  This resulted in the page at least rendering.  At this point the listener was active, but the Mapguide server could not be found.

MapGuide Server #1 [Local] Autodesk MapGuide Server could not be found. If you need more assistance, please contact your Autodesk MapGuide Server Administrator.

This looked similar to the that occurred back on XP when you applied Windows XP service pack 2 – but the server service was running.  I checked the DCOM permissions and everything there was correct.  After a bit of messing around I realized that indeed this Windows server was hardened and the permissions has been restricted.  To resolve this problem I had to give the local Users group read and execute permissions to the Mapguide folder.  I had to give the local Users group write access to the logs folder.   After that the mapagent could talk to the server no problem!

Now I admit I screwed up troubleshooting 101 here.  I had a hard stop coming and really needed to get this resolved ASAP.  Instead of doing one thing at a time and testing I added both permissions.  When I tried to undo the permissions to see if I could replicate the problem I could not reproduce it.  It may be possible that I only needed to give the local Users group modify access to the logs folder.  If you encounter this problem and determine this to be the case please let me know!

If you’re having problems with Mapguide 6.5 and could use a little help or if you would be interested in upgrading your system to Mapguide Enterprise or Open source – feel free to contact me via .  We’d love to help.

 

Technorati Tags: ,,,

14 comments on this post.
  1. Lloyd Lin:

    I followed your instruction and installed Mapguide6.5 on the Windows 2008 R2 server, I also had the IIS server setup per your instruction.
    I have the Autodesk MapGUide Author installed as well, I am able to have access to all the MWF files using Mapduide Author, my problem was to use the Web browser to open the mwf files, i received Autodesk MapGuide Server error 500. the event log shows Event ID:108, Source: Mapguide6.5. I have checked all the settings and spent almost 2 days on the issue.

    Please help me with this one, any help is greatly appreciated!

    Regards,
    Lloyd Lin

  2. Eric C Stone:

    This article has been very helpful. Everything works up to the rendering. The issue is with the data source definition. Our implementation utilizes the “Autodesk Spatial Data Provider for SDF”. We receive “Provider cannot be found”. Has anyone been able to resolve this issue?

  3. Darrin Maidlow:

    Hi Eric,

    Glad you found this helpful. I did start to work on the SDF provider. All signs pointed to increased registry permissions – though I ran out of investigation time and shelved that research as the SDF provider was less urgent for our client at the time.

    darrin

  4. Darrin Maidlow:

    My apologies on the late response Lloyd – I did not receive a notification of your comment and only noticed it now! I would check that the mime type is allowed in IIS – see this url from Microsoft for more details : https://technet.microsoft.com/en-us/library/cc725608(v=ws.10).aspx

  5. Eric C Stone:

    Thank you for your reply. I tried the mime type suggestion but that didn’t do the trick. Taking IIS out of the loop, I tried to open the MWF in the MG Author which resulted in “The query posed to data source ‘xyz’ failed to execute” with an ORA-00903 error. The data source is not targeting the AudoDesk Spatial Data Provider for SDF.

    Is that provider proprietary to MapGuide or might there be another industry provider that satisfies the same standard?

  6. Darrin Maidlow:

    Hi Eric – I don’t have Mapguide 6.x currently installed so I’m going from memory. First the SDF provider in Mapguide 6.x is proprietary for the “old” SDF file format. Given that you’re getting an ORA-00903 I suspect your SDF has some linked Oracle tables. the 00903 error is “table not found” – which is good in that Mapguide is likely connecting to Oracle – you *should* just need to verify that the correct user/schema is connecting or make sure that the user connecting has read access to the table in question within Oracle.

  7. Eric C Stone:

    To clarify, the ORA is incorrect. I should be the provider for SDF. Although, the provider is not available. The UDL file contains the following:

    Provider=ASDPSDF.SDFSDP.1;SDF Search Path=D:\xxx\xxx\SDF;Default SRS=*XY-IN*

    I know I’m getting “bit” bit :) I need to find a provider for SDF that works on 64bit with MG6.5SP1.

  8. Darrin Maidlow:

    Ahh – there is no 64 bit SDF provider. You need to configure the IIS application pool to run in 32 bit mode. Not sure if you were referencing this URL but the IIS 7 Confiuguration section should get you there. If Oracle is involved you’ll need the 32bit client installed on the Mapguide IIS server. Having both x86 and x64 Oracle clients is a whole other can of unpleasantness ;)

  9. Eric C Stone:

    It’s on Win 2008 IIS 7.5. Enable 32bit is set to True. I don’t believe that’s the problem. Additionally, remember earlier, I was using the MapGuide Author tool which is the manual client utility which failed with the same error.

    When I try to open the UDL file, it displays “provider not found”. When I view the providers, the Autodesk Spatial Data Provider for SDF is not an option.

  10. Eric C Stone:

    Well Darrin, I slept on it and re-read your posts. I have it working up to a point. The layers that use the Autodesk Data Link data sources fail:

    An error occurred in the DWG Data Extension for data source “xyz” – (null)

    From the Author, viewing the properties of the layer, on the Data Sources tab, DWG Data Source, I can click on the Data source and they are displayed. Clicking on the Autodesk DWG displays what’s expected but when I click the Key table it fails.

  11. Darrin Maidlow:

    Eric – my apologies this comment has brought my memories back in line. I always had the SDF provider working – it was the DWG provider that I tried and did not succeed at getting going. One idea you might try – have you made sure that the drawing files are accessible to network service (or whichever account is running the IIS application pool?) For a simple test you could try putting all the file in a local folder and making sure “everybody” has full control on that folder and its contents.

  12. Darrin Maidlow:

    If you have Skype Eric I’m Darrin.Maidlow – might be easier for some back and forth. I’ll do what I can to assist.

  13. Eric C Stone:

    I submitted a comment on the LegacyX website requesting it be forwarded to you with me email address. I can set up a WebEx.

  14. Darrin Maidlow:

    Hi Eric – I got your note – please e-mail me directly at darrin (at) legacyx.ca. The online contact didn’t have your e-mail address which I’ll need to get fixed.

Leave a comment